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Notice: Alicat Scientific, Inc. reserves the right to make any 
changes and improvements to the products described in 
this manual at any time and without notice. This manual is 
copyrighted. This document may not, in whole or in part, be 
copied, reproduced, translated, or converted to any electronic 
medium or machine readable form, for commercial purposes, 
without prior written consent from the copyright holder.

Note: Although we provide assistance on Alicat Scientific 
products both personally and through our literature, it is the 
complete responsibility of the user to determine the suitability 
of any product to their application.

The manufacturer does not warrant or assume responsibility for 
the use of its products in life support applications or systems.

For more information regarding this or any Alicat product, please 
contact us at:

Alicat Scientific, Inc
7641 N Business Park Drive

Tucson, Arizona 85743
USA

Ph: 520-290-6060
 888-290-6060

Fax: 520-290-0109
email: info@alicat.com

Web site: www.alicat.com

5/29/2014 Rev.2   DOC-FVISIONMXMAN
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Welcome to Flow Vision™ Gas Blending Station
Flow Vision™ MX is a graphical software package that aides in the 
process of mixing gases. Currently, up to six Alicat Scientific, Inc. mass flow 
controllers are supported. 

System Requirements
Supported Operating Systems: Microsoft® Windows® XP, Windows® 
Vista, Windows® 7
Software:  Microsoft®.NET Framework 3.5
Hard Disk:  Up to 10 MB of available space may be required for 
installation. Data logs may require additional space.
Hardware: Available COM port, at least one Alicat Scientific, Inc. mass flow 
controller
Display: Minimum of 860 x 860
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Overview

1. Device Gas: The gas that the target device is set to flow.
2. Device Model Number: The model number of the target device.
3. Device Serial Number: The serial number of the target device.
4. Actual Mass Flow: The current mass flow measurement of the target device.
5. Device Set-Point: The current set-point (target flow) of the target device.
6. Actual Percent: The actual concentration percentage of the gas that the 

target device is flowing. This will vary with the actual flow of all devices.
7. Target Percent: The target concentration of the gas in the overall blend.
8. Blend Composition: The makeup of the final gas blend.
9. Actual Total Flow: The total flow of the final gas blend.
10. Error: The flow error in terms of the target flow.
11. Maximum Flow: The maximum flow rate that can be reached.
12. Target Blend Flow Rate: The target rate of flow for the blend.
13. Start/Stop Mixing Button: Button to start/stop the mixing process.
14. Monitored Device: A device that is monitored during the mixing process.
15. Empty Location: An empty location that is available for mix components 

or monitored devices.
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Creating a Blend
If you are not mixing, double click any of the six empty mix component locations.
If you are already mixing, select File > New Blend from the menu to create 
a new, empty blend. Any existing blend information will be removed from the 
application. Double click any of the six empty mix component locations.

Select Mixing to add a device that will be used for gas mixing. Enter the 
following information: 

Device Identifier: The alphabetic identifier of the device you wish to use. 
COM Port: The RS232 port that the device is connected to.
Mix Percentage: The percentage of the final gas mix that this device will 
contribute. This can be changed later.
Alarm at Pressure: If the pressure drops below this level Flow Vision™ 
MX will generate an alarm. 

Click the “Add Mix” button to continue. 
Flow Vision™ MX will search for a mass flow controller using the selected 
parameters.
If the device is found, it will be added to the current mix.
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Blending Gases
Adjusting Concentrations
The concentration of each gas in the overall mix 
can be adjusted in three ways. 
The background of the Percent of Mixture gauge 
can be clicked (1) to change a concentration to a 
selected value. 
The indicator on the right of the gauge (2) can also 
be dragged up and down to adjust the value. 
Finally, the value can be edited directly in the box 
under the gauge (3).
Mixing cannot begin until the total of all 
concentrations reaches 100%. 
When this occurs, the “Start Mixing” button is 
enabled.

Devices that are at zero percent will not be represented in the final 
blend readings. 

Controlling these devices outside of Flow Vision™ MX will create 
inaccurate blend readings. 
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Changing Flow Rates
When the total of all concentrations reaches 100%, 
the “Start Mixing” button becomes enabled. 
Clicking this button will start the mixing process. 
Once mixing has started, the individual gas 
concentrations can not be modified. 
The percentages are unlocked when the mixing 
process ends.
The output rate of your gas blend can be changed in 
three ways. 
The background of the Master Gas Mix gauge can be 
clicked (1) to change a flow rate to a selected value.
The indicator on the right of the gauge (2) can also 
be dragged up and down to adjust the value. 
Finally, the value can be edited directly in the box 
under the gauge (3).
To stop the mixing process, click the “Stop Mixing” 
button. 
All device set-points will be set to zero and the gas 
flow will cease.
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Moving Components
To move a component to an empty location, left-click on the item and hold 
down the mouse button. Drag the item to the desired location.

Removing Components
To remove a component, left-click on the item and hold down the mouse 
button. Drag the item to the bottom right of the application. Release the 
mouse button when the item is over the image of a trash can.

Saving a Blend
Begin by selecting File > Save Blend from the menu. 
You will be prompted for a location on disc to store your blend. 
Enter a file name and click the “Save” button. 
Blends are stored using the .fvb extension in XML format and can be modified 
using a text editor.

Loading a Blend
Choose File > Load Blend from the menu to launch the open file dialog. 
Navigate to the desired blend file (.fvb) and click the “Open” button. 
The stored blend will be loaded, overwriting any existing blends.

Loading Recent Blends

Recent blends are added to the menu under File > Recent Blends. Selecting 
the blend name will load it into Flow Vision™ MX.
Recent blends can be loaded quickly by holding down the Control key and 
pressing the Tab key. Press the Tab key to iterate through the last six blends. 
Release the Control key while a gas is loaded to highlighted to load it.

Components cannot be removed while blending.
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Data Acquisition
Flow Vision™ MX allows you to capture the data returned by the devices 
while mixing. To enable data acquisition, select File > Data Acquisition > 
Start from the menu or press the Ctrl + Q keys.  
To view the log files, select File > Data Acquisition > View Folder from the 
menu. Logs are stored with the date and time that the acquisition was started 
in the file name.  

Changing Flow Units
By default, all flow readings in Flow Vision™ MX are in SLPM. 
The units can be changed by selecting the desired units from the Edit > Flow 
Units menu.

Changing Decimal Places
By default, all flow readings are shown to two decimal places. 

Decimals can be increased or decreased using the Edit > Decimals menu.

Increasing the decimal places will not increase the resolution of the devices. 
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Using the Terminal
The terminal allows for basic RS-232 communication with your Alicat 
Scientific™ devices while gases are being mixed. 
To launch the terminal, select View > Terminal from the main menu. 

Select a valid port from the COM Port menu to begin communications. 
Commands are entered into the box at the bottom of the terminal. 
Send a command by clicking the “Send” button. 
For more information on the standard Alicat Scientific™ command set or 
RS-232 communications, please see the operating manual for your device.

Monitoring a Device
The device monitoring functionality allows you to interact with a device that 
may not be part of your current gas blend. Devices that are part of your blend 
may also be monitored.
To add a device, double click any empty mix component location. Select 
Monitoring to add a device that will be used for monitoring. Enter the 
following information: 
Device Identifier: The alphabetic identifier of the device you wish to use.
COM Port: The RS-232 port that the device is connected to.
Click the “Add Device” button to continue. 
Flow Vision™ MX will search for a device using the selected parameters. If 
the device is found, it will be added to the current mix.
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Changing the Set-Point

The set-point on a monitored controller can be changed by clicking on the 
current set-point value. The field will become editable. Type in the desired 
set-point and press the Enter key. If the set-point is valid, it will be changed 
on the device.

Set-points cannot be changed while mixing.
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Changing the Gas
To change the gas of a monitored device, click on the current gas value. 

Then select the desired gas from the list of available gases.

The gas cannot be changed while mixing.
The selected gas should match the actual gas being flowed. 
If the gases do not match, flow readings will be inaccurate. 
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Pressure Limiting
The pressure limiting feature of Flow Vision MX allows you to automatically 
stop mixing when a monitored pressure exceeds a set value. When pressure 
surpasses your preset limit, Flow Vision MX closes the valves on the mixing 
devices. When pressure drops below a low limit, mixing resumes.

Overview
1. Visual High Limit: A visual representation 
of the high limit. If the current pressure 
exceeds this, mixing will stop.
2. Visual Low Limit: A visual representation 
of the low limit. If the current pressure falls 
below this limit, mixing will resume.
3. Visual Current Pressure: A visual 
representation of the current monitored 
pressure.
4. Current Pressure: The current monitored 
pressure. 
5. High Limit: An interactive representation 
of the high limit. 
6. Low Limit: An interactive representation 
of the low limit. 
7. Enable/Disable: Allows you to enable 
and disable the limit.

Adding a Pressure Limit  
Double click any of the six locations in the application. Select “Pressure 
Limit Switch” from the list of available options. Enter the following 
information:
Device Identifier: The alphabetic identifier of the device that will be used to 
monitor pressure. 
COM Port: The RS-232 port that the device that will be used to monitor 
pressure is connected to.
Click the “Add Device” button to continue. The pressure limiting view will 
be added to the application.
Flow Vision MX will search for a device using the selected parameters. If 
the device is found, it will be added to the current mix.
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Real Time Pressure Feedback
Real time pressure feedback allows Flow Vision MX to control the flow of 
your gas mix based on a desired pressure. The application uses a control 
algorithm to adjust the flow of mix in real time to maintain pressure.   
To add a pressure feedback device, double click any empty mix component 
location. Select “Pressure Feedback” to add the device that will be used 
monitor pressure. Enter the following information:
Device Identifier: The alphabetic identifier of the device you wish to use.
COM Port: The RS-232 port that the device is connected to.
Set-Point: The pressure that you would like to maintain, in the device’s 
pressure units.
Click the “Add Device” button to continue.
Flow Vision MX will search for a device using the selected parameters. If the 
device is found, it will be added to the current mix.

Tuning Pressure Feedback
Flow Vision MX uses a modified PID control 
algorithm to maintain pressure at a set-point.  
The proportional (P) and derivative (D) terms 
can be adjusted by opening the Settings 
menu and changing the appropriate values.  
For more information on PID control and 
tuning, please see http://en.wikipedia.org/
wiki/PID_controller.
While mixing with pressure feedback, Flow 
Vision will control the output of your mix. 
If you would like to disable this behavior, 
press the “Disable Feedback” button under 
the Settings menu.
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